A volte capita che alcuni computer nel network vengono infetti da virus che poi usano il pc del povero cliente come server SMTP e diventano dei veri e propri nodi che inviano SPAM a tutto il mondo.

Mikrotik ci viene incontro con queste due semplici regole:

/ip firewall filter

add chain=forward protocol=tcp dst-port=25 src-address-list=spammer action=drop comment=”BLOCK SPAMMERS OR INFECTED USERS”

add chain=forward protocol=tcp dst-port=25 connection-limit=30,32 limit=50,5 action=add-src-to-address-list address-list=spammer address-list-timeout=1d comment=”Detect and add-list SMTP virus or spammers”

Personalmente queste due regole le ho applicate ai vari BRAS sparsi nel nostro network in modo da debellare gli SPAMMER e non far finire i vari ip dei poveri clienti nelle varie liste di blacklist.

maggiori info: http://wiki.mikrotik.com/wiki/How_to_autodetect_infected_or_spammer_users_and_temporary_block_the_SMTP_output